Authenticatie problemen Gigaset S450

  • 2 February 2023
  • 66 reacties
  • 2728 Bekeken

Reputatie 3

Hoi,

Ik heb de Gigaset S450 via SIP aangesloten op de T-mobile verbinding. Deze zit via een (Cisco) router aan de glasvezel, dus geen Zyxel router van T-mobile.

Probleem wat ik ervaar is dat ik een “Registration failed” error krijg op de Gigaset (niet heel veelzeggend).

Even kijkend naar het verkeer op de firewall zie ik:

SIP/2.0 401 Unauthorized

Dat zegt mij dat de SIP proxy/registrar en de Gigaset in weze wel babbelen, alleen het nog niet eens zijn over welke klant contact wil leggen.

Username heb ik uit de My T-mobile instellingen gehaald, en het wachtwoord is gewijzigd en correct ingetypt.

Ik vermoed dat ik een cruciaal detail uit de draadjes op het forum gemist heb, kan iemand mij hier op wijzen?

 

Groet,

Michel

 

Inloggegevens
Codecs
DTMF instellingen

 

 

TMTV 1 jaar geleden

Hi all!

De oplossing voor de problemen met het VOIP-wachtwoord laat nog even op zich wachten, maar een vraag in mijn oude topic bracht me op een idee voor een tijdelijke workaround. Ik heb mijn oude VOIP-script afgestoft en weer online gezet. Zo kun je in afwachting van een permanente oplossing toch vooruit met je eigen apparatuur. Het script werkt zowel voor mensen die hun VOIP-wachtwoord niet hebben gewijzigd (dus het standaardwachtwoord van T-Mobile hebben), als voor mensen die een eigen wachtwoord hebben ingesteld, al dan niet sinds de problemen zijn ontstaan. Voor die laatste groep geldt dat het wachtwoord dat het script laat zien dus compleet anders is dan wat je hebt ingesteld, maar dit is wel het daadwerkelijke wachtwoord dat bij de server bekend is. Het lijkt alsof het Base64-gecodeerd is, maar dit is het letterlijke wachtwoord waarmee je je kunt registreren. (Decoderen levert overigens niets bruikbaars op, zeker niet het wachtwoord dat je zelf hebt ingesteld.) Met dit script kun je je VOIP-wachtwoord alleen zien, niet aanpassen.

Het script dat in de post hierboven gelinkt wordt, heb ik oorspronkelijk gemaakt om te gebruiken in combinatie met de Zyxel T50, maar werkt ook met de T54, de Draytek 2132FVn en een eigen router. Het is al een tijdje geleden, maar bij mij doet ‘ie het met de Python-versie van dat moment nog steeds. Verder heb ik het niet getest, dus als het werkt (of niet), laat het hier even weten.

Succes!

TMTV

Bekijk origineel

66 reacties

Reputatie 7
Badge +4

Hi @Michel Stam ,

Hoeveel tijd zat tussen het proberen en het uitzetten van de Zyxel? 

Je mag maar 1 registratie tegelijk hebben voor een Sip account. Kan zijn dat die van de Zyxel nog niet verlopen is aan de kant van de Sip server. Probeer het na iets meer dan een uurtje nogmaals.

Reputatie 3

Hi @Michel Stam ,

Hoeveel tijd zat tussen het proberen en het uitzetten van de Zyxel? 

Je mag maar 1 registratie tegelijk hebben voor een Sip account. Kan zijn dat die van de Zyxel nog niet verlopen is aan de kant van de Sip server. Probeer het na iets meer dan een uurtje nogmaals.

Hey @Sven-TMT, goeie tip!

 

Inmiddels denk ik 1.5 dag. Ik heb het dinsdagavond om zeg even 21:45 omgezet en laten draaien. Ik heb zojuist even de lijn “uitgeschakeld” in de webinterface van de S450, dus zal hem nu een uurtje uit laten.

Gr

Michel

Reputatie 3

Ok, ruim een uur uit gehad, helaas, direct weer de “registration failed”. Helaas.

Moet er een domein aan de username geplakt worden? of zuiver de username zoals in de plaatjes?

Reputatie 7
Badge +4

Ok, ruim een uur uit gehad, helaas, direct weer de “registration failed”. Helaas.

Moet er een domein aan de username geplakt worden? of zuiver de username zoals in de plaatjes?

Als de client dat niet automatisch doet wel ja. 

Authentication name; xxxxxxxp006@voip.t-mobilethuis.nl

Reputatie 3

Ok, ruim een uur uit gehad, helaas, direct weer de “registration failed”. Helaas.

Moet er een domein aan de username geplakt worden? of zuiver de username zoals in de plaatjes?

Als de client dat niet automatisch doet wel ja. 

Authentication name; xxxxxxxp006@voip.t-mobilethuis.nl

 

Ok lijkt te kloppen, ik heb even de packet sniffer opengezet:

 

 

Reputatie 3

Probleem is niet opgelost. Het pakket zoals dat uitgestuurd wordt door de Gigaset lijkt te kloppen. Maar daar mee is de authenticatie niet opgelost. Antwoord is nog steeds hetzelfde. Graag draadje open laten.

 

Groet,

 

Michel

Reputatie 7
Badge +6

@Michel Stam Toevallig (of niet?) lees ik hier een vergelijkbaar verhaal. Daarom voor jou dezelfde vraag: kun je het eens testen op een ander apparaat, bijvoorbeeld met een VOIP-app op je telefoon? Zo kunnen we controleren of de Gigaset de boosdoener is. Zorg er wel voor dat je telefoon met je Thuis-wifi verbonden is. Op andere aansluitingen is de VOIP-server niet bereikbaar.

Reputatie 3

@Michel Stam Toevallig (of niet?) lees ik hier een vergelijkbaar verhaal. Daarom voor jou dezelfde vraag: kun je het eens testen op een ander apparaat, bijvoorbeeld met een VOIP-app op je telefoon? Zo kunnen we controleren of de Gigaset de boosdoener is. Zorg er wel voor dat je telefoon met je Thuis-wifi verbonden is. Op andere aansluitingen is de VOIP-server niet bereikbaar.

Bij mij werkt het ook niet. Het lijkt toch echt te liggen bij T-Mobile. Er is ook iets mis met My T-Mobile ik kan mijn mobiele abonnement niet toevoegen en mijn naam wijkt af van die op mijn gebruikte identiteitsbewijs. 

Reputatie 3

@Michel Stam Toevallig (of niet?) lees ik hier een vergelijkbaar verhaal. Daarom voor jou dezelfde vraag: kun je het eens testen op een ander apparaat, bijvoorbeeld met een VOIP-app op je telefoon? Zo kunnen we controleren of de Gigaset de boosdoener is. Zorg er wel voor dat je telefoon met je Thuis-wifi verbonden is. Op andere aansluitingen is de VOIP-server niet bereikbaar.

Hey @TMTV,

Ik heb het eigenlijk direct geprobeerd met de app Groundwire, op de telefoon, vanaf het T-mobile netwerk, 4G en een andere glasvezelverbinding (niet T-mobile). Zelfde reactie, voor zover ik dat kan zien in elk geval, debug op de telefoon is niet heel uitgebreid.

 

Reputatie 3

Zijn er bepaalde karakters die, ondanks dat je ze kan invullen, niet gebruikt mogen worden als wachtwoord?

Reputatie 7
Badge +6

@Michel Stam Testen op een ander netwerk dan de vaste aansluiting van TM Thuis heeft sowieso geen zin, omdat de VOIP-server daarop niet bereikbaar is. Het wachtwoord moet minimaal 1 speciaal teken bevatten. Kun je een wachtwoord maken met alleen een streepje (-) als speciaal teken? Daarvan weet ik zeker dat het werkt. Zo kunnen we een ‘verkeerd’ wachtwoord uitsluiten.

Reputatie 3

Zojuist een wachtwoord aangemaakt met letters, cijfers en een streepje. Mee eens, dit zou moeten werken.

Edoch, nog steeds de error.

 

@Tommie zou je het draadje open willen laten en niet als oplossing willen flaggen? Ik beloof van mijn kant dat ik een signaal geef als de oplossing gevonden is, maar ik kan niet elke dag testen, omdat dit de verbinding van mijn ouders betreft, niet mijn thuisverbinding. Er is af en toe wat reizen noodzakelijk.

Reputatie 3

Mijn volgende stap is het Zyxel modem even aansluiten op mijn lokale netwerk hier (niet t-mobile) en met Wireshark sniffen wat er precies aan SIP berichten voorbij komt. Niet heel triviaal dus zal even op zich laten wachten.

Reputatie 1

Ik heb een Gigaset Go Box 100 met een S850A en initieel had ik ook het Registration Failed probleem voor het T-mobile SIP Account. Ik heb bij Advanced VoIP Settings de optie “Use random ports for SIP” op “Yes” gezet en toen deed die het na een reboot van de Gigaset. Ik gebruik een eigen Asus router.

 

 

Reputatie 1

@Michel Stam 

Zet ook je Registration refresh time in de Advance Settings van het SIP account op 3600s. Heb ik hier gelezen. https://community.t-mobile.nl/thuisnetwerk%2D539/eigen%2Dmodem%2Dwat%2Dzijn%2Dde%2Dvereisten%2D339306

 

 

 

Reputatie 3

Hey @kachun 

Dank voor de tip, zal het omzetten. Heeft op dit moment nog geen effect omdat de authenticatie faalt. De timer loopt pas als dat gelukt is, maar het is goed te weten hoe vaak de refresh nodig is.

De random ports hadden overigens om dezelfde reden geen effect. Wel geprobeerd.

Groet,

Michel

Reputatie 1

@Michel Stam 

Voor de volledigheid mijn t-mobile SIP instelling. 

 

Ik had mijn abonnement 2 dagen terug aangepast (niet meer gratis bellen) en toen werkte het niet meer, maar nadat ik het wachtwoord weer had gewijzigd en geconfigureerd had, ging de registratie weer goed. Misschien als je de Zyxel weer gekoppeld hebt, dan reset die het wachtwoord weer. Maar ik weet niet of je dat gedaan hebt, maar zo ja dan moet je weer nieuw wachtwoord instellen. Ik had initieel een $ teken in mijn wachtwoord en dat werkte niet, daarna een % teken gebruikt en dat werkte wel. Blijft een mysterie. Maar die random port instelling was voor mij wel essentieel voor een succesvolle registratie. Moet je misschien anders port 5060 gaan forwarden.

Reputatie 3

Hey @kachun 

 

kan zijn dat dat iets is wat tmobile eist, poort 5060. Dan gaan de meeste nat implementaties op hun gat.

 

wachtwoord resetten heb ik al tig keer gedaan, ik heb weinig hoop, nu iets met een - er in.

Ik vermoed dat de giga set implementatie wat liberaal omgaat met het sanitisen van input velden, % zou dan bijvoorbeeld een UNICODE karakter kunnen worden, $ is vrij gebruikelijk als variabele in scripting talen, and so on…. Maar dat is gis werk

Grt

 

Michel 

Reputatie 1

hi @Michel Stam ,

 

in de router is er een instelling SIP ALG. Dat zou je uit kunnen zetten. Dit wordt op internet aangeraden als je problemen ondervindt met de verbinding.

Reputatie 3

Ok excuses voor de vertraagde reactie,

Ik heb mijn laptop met 2 1Gbps interfaces in bridge mode tussen de internet verbinding en de Zyxel gezet, en captures gedaan met Wireshark. Vervolgens het Zyxel modem voor het Cisco modem uitgewisseld en dezelfde truc herhaald.

Allereerst het Zyxel modem:

En het bijbehorende antwoord (het gaat overigens 3 keer fout, daarna goed, ik neem aan dat er nog een password met de t-mobile backend gesynchroniseerd moest worden):

De Zyxel kan duidelijk registreren. Nu dezelfde truc met de Gigaset (via de Cisco router).

Registratie:

Het antwoord is echter verschillend:

Wat me nu opvalt:

  • Het source IP van het modem is 31.187.x.y als het Zyxel modem wordt gebruikt, en 95.98.a.b als het Cisco modem wordt gebruikt.
  • De source port is 5060 bij het Zyxel modem, en 1499 bij de Gigaset
  • De contact header is 5060 bij het Zyxel modem, en 1500 bij de Gigaset
  • De User name (From/To) is het telefoonnummer bij de Gigaset, en het ***P006 klantnummer bij de Zyxel

Deze laatste (Username) heb ik gefixed in de Gigaset om te kijken wat het verschil was, uiteraard ook het password in de portal opnieuw aangepast om zeker te zijn dat dat niet gewijzigd is.

Dit werkt dus nog steeds niet. Ik had overigens begrepen na een telefoongesprek, inmiddels 1 maand geleden dat T-mobile nog contact zou opnemen over dit probleem, maar nog niets gehoord. Ik hoop nog wat van jullie te vernemen, T-mobile.

Groet,

Michel

Reputatie 1

Ik heb hier hetzelfde probleem maar dan met een N300a. Alle settings geprobeerd, maar helaas nog steeds Failed to register.

Reputatie 1

Ik heb gisteren de migratie gehad van KPN naarn TM thuis met het Zyxel modem. Mijn diensten zijn alleen internet en telefonie. De Zyxel is vervangen door een Edgerouter met vlan300 actief. Maar als ik kijk naar de netwerk instellingen van de Zyxel, valt me op dat er een 10.x netwerk leeft. Voor internet is dit niet nodig, dus ik vraag me af of dit netwerk misschien toch is voor telefoniedienst of uitsluitend voor t-mobile zelf om eea te managen van het modem.

  • ETH_MGNT - 10.68.xxxxx - 255.255.0.0
  • IPoE - D4:1A:D1:xxxxx
  • DNS: 62.58.48.20   37.143.84.228

Verder kan ik in de gigaset N300 geen volledige “Authentication name” invullen, het veld is te kort. (.nl valt dan weg). De “username” kan wel met volledige URL ingevuld worden. 

Settings die ik geprobeerd heb:

  • Use random ports for SIP.
  • set system conntrack modules sip disable (edge router).
  • Voip wachtwoord veranderd - alleen een “-” als symbool.
Reputatie 3

Ik zou hier graag even met T-mobile over spreken, e.e.a. moet mogelijk zijn.

Moderators, zouden jullie dit naar de 2e lijn willen escaleren of hebben jullie liever dat ik het noc zelf benader?

 

mvgr

 

Michel

Reputatie 6
Badge

Ik heb gisteren de migratie gehad van KPN naarn TM thuis met het Zyxel modem. Mijn diensten zijn alleen internet en telefonie. De Zyxel is vervangen door een Edgerouter met vlan300 actief. Maar als ik kijk naar de netwerk instellingen van de Zyxel, valt me op dat er een 10.x netwerk leeft. Voor internet is dit niet nodig, dus ik vraag me af of dit netwerk misschien toch is voor telefoniedienst of uitsluitend voor t-mobile zelf om eea te managen van het modem.

  • ETH_MGNT - 10.68.xxxxx - 255.255.0.0
  • IPoE - D4:1A:D1:xxxxx
  • DNS: 62.58.48.20   37.143.84.228

Verder kan ik in de gigaset N300 geen volledige “Authentication name” invullen, het veld is te kort. (.nl valt dan weg). De “username” kan wel met volledige URL ingevuld worden. 

Settings die ik geprobeerd heb:

  • Use random ports for SIP.
  • set system conntrack modules sip disable (edge router).
  • Voip wachtwoord veranderd - alleen een “-” als symbool.

@Michel Stam : het grote verschil in jouw traces is de response van de VOIP server: dat is een 401 (unauthorized), blijkbaar gaat er iets fout met authenticatie. Het zou interessant zijn om bij de Zyxel ook de tussenliggende (wat jij failed) attempts te zien. Het zou mij niet verbazen als dat ook begint met een 401 waarna de Zyxel een tweede poging doet met  een authenticatie gebaseerd op de nonce (hash key) die is ontvangen van de SIP server. De REGISTER - 401 met nonce + hernieuwde register MET authenticatie details is normaal.

De Gigaset Zou na de 401 met nonce opnieuw moeten proberen te registreren met de authenticatie details. Als ie dat niet opnieuw probeert lijkt me dat een Gigaset probleem.

Hoe dan ook: om de verschillen in detail te analyseren heb je dus een meer uitgebreide trace nodig pm een hint te krijgen voor waar het echt fout gaat.

Je Cisco heeft een ander dynamisch IP-adres gekregen, en zal dat als source adres gebruiken. Niets vreemds aan

@cb2023 : dat 10.68.x.y adres is inderdaad uitsluitend voor management (op VLAN100) en heeft niets met VOIP te maken.

Ik heb helaas geen VOIP van T-mobile en kan zelf niet testen. Ik weet dat mijn zoon een fritzbox voor VOIP achter een edgerouter werkend heeft. Ik zal hem eens vragen wat zijn instellingen zijn. Het werkte bij hem vrijwel  direct.

En test altijd 2 maal: met SIP ALG uit en aan. Soms werkt het met de setting aan, soms juist met de setting uit. Die SIP proxies werken op verschillende routers anders dan op andere.

SIP is nu eenmaal een complex protocol (hoewel het beter is dan het H.323 die het vervangt, dat was helemaal een ramp)

Reputatie 1

@louisL Ik heb meerdere keren geprobeerd de conntrack module te enablen/disablen, echter zonder succes. Zou het uitmaken, dat in het Zyxel modem eerst SIP activatie/registratie gedisabled zou moeten worden voordat deze afgekoppeld is van het netwerk?

 

Reageer