Newly installed Wi-Fi doesn't show up in available network

  • 3 October 2022
  • 19 reacties
  • 265 Bekeken


I have got a new Wi-Fi connection (Zyxel T-50).  But, I don't see wi-fi connection in the available network list.

My laptop works fine with other wi-fi networks (it was ziggo till last week) and with my phone via tethering. so I don't think issue is with my laptop.

Laptop Details: Dell Latitude E7240 with Intel Dual Band wireless-AC 7260 NIC.


I can see other TMNL-…. wi-fi networks on the list (probably from my neighbors) but I don’t see my wo-fi on the list of available network.


The wi-fi works on my other laptop (from my work) - so it seems some configuration at router/modem needs to be adjusted to make it work. 

Please check


Beste antwoord door Sven-Odido 4 October 2022, 18:01

Bekijk origineel

19 reacties

Reputatie 7
Badge +14

Hello @Ashmeet 

Can you browse to, login with admin and the Login Password behind the Zyxel and turn off 5 GHz under WiFi instellingen?

Try to connect the laptop again.

hi @Waqqas ,

Just turned off 5 Ghz but the issue still exists.

Reputatie 7
Badge +14


And when you log in to the Zyxel interface, go to the menu, netwerkinstellingen, draadloos, scroll down to beveiligingsmodus and choose geen, click on toepassen and try to connect the laptop again.

Afterwards you can select WPA2-PSK again, it's just for a test.


There is no “geen” as an option. I only see 3 items in the drop down :

WPA3-SAE/WPA2-PSK (selected)




Reputatie 7
Badge +14


Select WPA2-PSK then and it should work. You have the Zyxel-T54 then and not the Zyxel-T50.

@Waqqas - Indeed, its T54.

And, I changed it to WPA2-PSK but its still not showing in the list of available network. 

So, issue still exists

Reputatie 7
Badge +14


Is 5 GHz still disabled? Otherwise go back to WPA2/WPA3, sometimes it works.


Yes, 5Ghz is still disabled. I did try multiple options, see below. But issue still exists.

WPA3-SAE/WPA2-PSK (selected) - works for some laptops

WPA2-PSK - works for some laptops

WPA3-SAE - wifi signal is not shown in available network for all laptops.

Reputatie 7
Badge +4

Hey @Ashmeet,

Thanks for the detailed information that you’re posting!

It seems that the usual tips don’t work. I would love to give you advanced tips but this site is both better in explaining as well as visualizing them: Wifi tips. Especially from method 10 onward it seems to get quite thorough in the investigation of why your laptop cannot connect to the Wifi.

I hope for you and I am curious to hear if the tips helped you out! 

@Cal - Thanks for sharing the link.

I had already tried most of the stuff but i still went through it and tried all methods from 11 to 14. 

Still no luck.

Long shot, since I do see other TMNL networks - is possible to compare the what's the difference in the router settings for these networks ? If yes, how can I share these details

Hi @Ashmeet

We made some small changes can you check wheter you can see the network now? 

If not it might be indeed hulpfull to share the TMNL- networks you can see on the laptop. Please sent them in a private message to me or @Lisa 

@Sven-TMT - Its working now. I can connect my laptop to the wifi but the speed is considerably reduced (from 400 to 80) .Can you check this also pls

@Ashmeet Due to the changes we made the clients where connected to the 2.4Ghz instead of the 5Ghz. I forced them to switch (disabled the 2.4ghz for a sec) i can now seem them on the 5Ghz. Can you check again. 

@Sven-TMT - Its working now and seems to be fixed. Please keep it this way :)

Would like to monitor the speed/connectivity for next 24 hrs before considering this resolved. 

Can you share what changes you made to fix connectivity ?


@Ashmeet Happy to hear 😁

I Looked at the modem type the neighbour has. There are two difference between you and the neighbours; WPA2/WPA3 security and Wifi6. 

Since the tried the WPA2 trick @Waqqas mention without result the only thing is the Wifi6. 

I disabled the Wifi6 (802.11AX). Under Home Networking - Wireless - Others - 802.11 Mode.

You are now running on Wifi5 (802.11AC) just like the neighbours. Im thinking that the network card  in your laptop have some troubles with AX wifi networks. You check with intel whether a driver update is needed to fix that if you want. But as long as you don't have any Wifi6 clients there is no disadvantage for you. Just keep it in mind to change it back when you upgrade to Wifi6 clients :) 

Reputatie 7
Badge +14


Good to know that because others are having the exact same issue but disabling WiFi 6 was never tried 🙂

@Waqqas Your Welcome! 

Its just like the WPA2/WPA3 Transition mode. Some devices and network card don't like it . 

I would recommend trying these two options before splitting the SSID (Personally) 😉. 

@Sven-TMT - Thanks a lot for helping out and proving the solution. 

@Waqqas @Cal - Appreciate your help as well. Thank you!


@Sven-TMT - Thanks a lot for helping out and proving the solution. 

@Waqqas @Cal - Appreciate your help as well. Thank you!


Happy to help :)